Samba setup on Xubuntu (Gutsy)

Open baby

Samba setup on Xubuntu (Gutsy)

Postby intodis » 05 Feb 2008, 22:16

This details setting up samba for sharing Xubuntu shares with Windows and also configuring Thunar to access samba shares
(I didn't care about Xubuntu writing to windows clients, but I did care about windows writing to Xubuntu ...)

Setting you SAMBA on Xubuntu and adding a Network shortcut to Thunar
refer: http://ubuntuforums.org/showthread.php?t=304131&highlight=xubuntu thanks Tazix

Thunar doesn't have native network Browsing, here is a good way to accomplish it:
  1. In XFCE's Applications -> System -> Shared Folders. (This should trigger a Samba install if you don't already have a share, and it should allow you to define the proper workgroup)
  2. Install fusesmb in Synaptic (from Universe repository)
  3. Edit /etc/modules and add the word 'fuse' to the modules list to be loaded (without quotes), and save the file.
  4. Reboot, so the fuse module loads, and the proper workgroup is read for samba.
  5. In XFCE Applications -> System -> Users and Groups... Properties of your username... User Priveleges Tab... check "Allow use of fuse file systems..."
  6. Create a directory that you are going to mount your network browse to... I used /media/network. Change permissions to read / write for group and others (777).
  7. In a terminal, type: sudo chown <username>:fuse /media/network (Where <username> is your user account logon name)
  8. Double check that the permission to use fuse took. Applications -> System -> Users and Groups... Manage Groups... find fuse and choose properties. Make sure your user name account is in that group and check-marked. (IMPORTANT!)
  9. Reboot the system and triple check permission have been applied
  10. In XFCE Applications -> Settings -> Autostarted Applications... Add an application... name and describe as you wish... for command line, put: fusesmb /media/network (Or whatever mountpoint you created).
  11. Open Thunar, and navigate to the parent folder of your mountpoint... then drag the 'mounpoint folder' to the places (shortcut) pane of thunar.
  12. Logout and log back in (So the user privilege and fusesmb autostart will take affect)

If it doesn't work then recheck permission are enabled and your settings are correct, I had type in work group and permission didn't take on one machine first time I tried.

Setting up Xubuntu so that windows can logon to the share
refer: http://ubuntuforums.org/showpost.php?p=613745&postcount=7

  1. create a samba user
    Code: Select all
    sudo smbpasswd -a <username>
  2. enable it
    Code: Select all
    sudo smbpasswd -e <same-username-used-before>
  3. restart samba (you might get away without restart).

This last part was validated on Vista Home Premium writing to xubutnu.

That's Gold!
intodis
Site Admin
 
Posts: 204
Joined: 30 Mar 2006, 20:57

Return to Ubuntu/Linux

Who is online

Users browsing this forum: No registered users and 2 guests

cron